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1.    Introduction

SuperClip is a clipboard viewer that can save all or part of the image on the clipboard
to a graphics file in BMP, GIF, PCX, or TIF format.    The 32-bit version of SuperClip for
Windows 95 & NT also supports the PNG graphical file format.

In Windows, the entire screen can be captured to the clipboard at any time by pressing
the PrtSc key (Shift+PrtSc on 84-key keyboards), or just the currently active window by
pressing Alt+PrtSc.    Text can also be captured to the Windows clipboard by pressing
PrtSc while a DOS program is running full-screen in text mode.    SuperClip can save
clipboard text to an ASCII file or to a monochrome graphics file.

The SuperClip package includes a utility named DosClip that works in conjunction with 
SuperClip to capture to the Windows clipboard the entire screen from a DOS graphical 
application that is running full-screen in a DOS session under Windows.

2.    Installation - Windows 3.1

To install SuperClip into Windows 3.1 from a floppy disk, select "Run" from the File 
menu of Program Manager and enter "a:setup" or "b:setup," depending on which floppy 
disk drive you are using.    To install SuperClip from a ZIP file, un-ZIP SCLIP320.ZIP 
onto a floppy disk and install from the floppy as already described.    Or you may un-
ZIP SCLIP320.ZIP into an empty directory on your hard disk for temporary storage, 
then select "Run" from the File menu of Program Manager and enter the full path to 
setup.exe.    The name of the default directory into which setup will install the SuperClip 
files is SCLIP, which should not be the name of the directory you're installing from.    
Setup will now create the program group SuperClip in Program Manager, after which 
you may delete the files that were temporarily stored in the installation directory.

To remove SuperClip from your computer, run setup and select the "Remove" option.

3.    Installation - Windows 95 and Windows NT

To install SuperClip into Windows 95 or Windows NT from a floppy disk, select "Run" 
from the Start menu and enter "a:setup" or "b:setup," depending on which floppy disk 
drive you are using.    To install SuperClip from a ZIP file, un-ZIP SCLIP320.ZIP onto 
a floppy disk and install from the floppy as already described.    Or you may un-ZIP 
SCLIP320.ZIP into an empty directory on your hard disk for temporary storage, then 
select "Run" from the Start menu and enter the full path to setup.exe.    The name of 
the default directory into which setup will install the SuperClip files is SCLIP, which 
should not be the name of the directory you're installing from.    Setup will now insert 
the SuperClip icon into the Programs folder of the Start menu, after which you may 
delete the files that were temporarily stored in the installation directory.

To remove SuperClip from your computer, run setup and select the "Remove" option.



4.    Capturing the Windows Screen

SuperClip was designed to run minimized in "popup" mode, meaning it will pop up 
when you press the PrtSc key to capture the entire screen, or Alt+PrtSc to capture the 
currently active window.    You can then save the entire image or any rectangular portion.    
To return to the application that was interrupted, simply click on that application's 
window or minimize SuperClip again.    You can turn popup mode off by pressing Ctrl+M, 
or by clicking on "Popup" in the Options menu, which will remove the checkmark next
to this menu item.

SuperClip does not need to be running in order to make a screen capture.    Once you 
have pressed the PrtSc key, you can run SuperClip to display the clipboard.    You can 
then save the entire image or crop a rectangular area with the mouse or keyboard
before saving to disk.

To save a captured image to disk, choose the desired format from the File menu.    
A dialog box will list the files of the selected format in the current directory.    You 
may select one of the files listed or type a new file name in the edit box.    You may 
also switch to another directory or disk drive.

SuperClip will also display text captured to the clipboard by pressing the PrtSc key 
while a DOS character-mode application is running full-screen under Windows.    Two 
character sets are available for the display of text, OEM and ANSI, either one of which 
may be selected from the Options menu.    Text can be saved to an ASCII file or to a 
monochrome graphics file in any of the available formats.

While in popup mode, SuperClip will also pop up when another application puts onto 
the clipboard a bitmap that is compatible with SuperClip.    The compatible formats are 
DDB (Device-Dependent Bitmap) and DIB (Device-Independent Bitmap), two commonly-
used bitmap formats.    If you attempt to save a clipboard bitmap whose format is not 
one of these two, SuperClip will respond with a dialog box that says "No bitmap exists 
on the clipboard."

Because of the internal complexities of the popup feature, SuperClip will not allow more 
than one instance of itself to run.    Clicking on the SuperClip icon will therefore activate 
a currently-running instance if one exists, instead of launching a new instance.    This 
property can be put to good use if the SuperClip window should become hidden by 
another window; click its icon in the Start menu to make the SuperClip window visible.

5.    Capturing the DOS Screen

SuperClip can capture the screen to the Windows clipboard from either a text or a 
graphical mode DOS application that is running full-screen in a Windows DOS session.    
Normally, such captures are made by pressing the PrtSc key.    However, Windows is 
not always able to capture the screen to the clipboard from a DOS application that is 
displaying a full-screen graphical image.    In that case, Windows displays the message 
"Unable to copy screen contents into clipboard."    When this occurs, you can still make
the capture by activating DosClip, a utility that is included with SuperClip.

Before you can use DosClip, you must make it memory-resident in the DOS session 
before running the DOS graphical application.    To do this, first start a DOS session by 
clicking on the MS-DOS icon in Windows.    At the DOS prompt, type dosclip and press 
Enter.    The directory in which dosclip.exe resides should be included in the PATH 
statement of your autoexec.bat file, otherwise you will have to type the full path to 



dosclip.exe before pressing Enter.    Dosclip will now display the message "DosClip 
is now memory-resident" on the screen.    The message will also indicate whether or 
not the VESA BIOS extension is present, as DosClip needs this extension to capture 
SVGA screens.    If the VESA BIOS extension is not present, you will need to insert a 
line in autoexec.bat that runs a utility that installs the VESA BIOS extension in RAM.    
See the documentation for your video card for information about this utility.    For a list of 
the VESA modes supported by DosClip, see the Appendix at the end of this document.

After you make DosClip memory-resident in the DOS session, you can run your 
graphical DOS application.    Now, if pressing PrtSc fails to capture a graphical screen 
to the Windows clipboard, you can activate DosClip by pressing Ctrl+PrtSc.    DosClip 
will signal you with one or more beeps, depending on the screen mode, that it is making
the capture.    After the final beep, you may proceed working in the DOS application and
make additional screen captures.    Screen captures are saved to a series of sequentially-
named temporary files, starting with DSCLP000.BMP.    You can make up to 256 captures
in a series before the file name cycles from DSCLP255.BMP back to DSCLP000.BMP
and starts overwritng files of the same name.

You can switch back to Windows at any time by pressing Alt+Esc.    Your DOS session 
will now be running minimized so that you can return to it.    SuperClip will now open the 
first temporary file, place the image it contains onto the clipboard, then delete the file.    
It may be necessary to activate SuperClip by clicking on its title bar, if it is not the 
currently active window.    You can now save the clipboard image, print it, or perform
any of the transformations available in the Options menu.

To display the next captured image in the series, press Ctrl+N or select "Next DOS 
capture" from the "Display" menu.    After the last capture is displayed, selecting this 
menu item will display the message "No more DOS captures."    You may now return 
to the DOS session to make additional captures by clicking on the DOS session icon 
on the taskbar.    A new temporary series will begin, starting at DSCLP000.BMP.

The temporary BMP files are stored in the default WINDOWS\TEMP directory, unless 
you specify another directory by setting the TMP environment variable in autoexec.bat.    
The temporary BMP files created by DosClip are not really useful to any other applica-
tion besides SuperClip, as the images are inverted.    SuperClip automatically re-inverts 
the images before displaying them.    There is a practical reason for this image inversion;
contact the programmer if you need to know the technical details.

Although DosClip was designed to run in a Windows DOS session, it is possible to 
use DosClip on a machine that is running only DOS.    In that case, you should include 
the following line in the DOS autoexec.bat file:

set TMP=C:\WINDOWS\TEMP

This will enable SuperClip to find and display the DosClip temporary BMP files when 
you start Windows and run SuperClip.

6.    Cropping the Clipboard Image

The SuperClip display window can scroll the clipboard image horizontally and vertically 
by means of the scroll bars.    To mark a rectangular area for cropping, move the cursor 
to the top-left corner of the desired rectangle, depress the left mouse button, move the 
cursor to the lower-right corner and release the button.    Repeat this procedure to erase 
the rectangle and draw a new one.    The width and height of the rectangle in pixel units 
will be displayed in the title bar, as will the x (horizontal) and y (vertical) coordinates of



the upper-left (UL) and lower-right (LR) corners of the rectangle.    The origin of these
coordinates is the upper-left corner of the clipboard image.

You can use the keyboard to modify or enter rectangle coordinates.    To do this, select 
"Enter coordinates" from the Options menu.    The dialog box will allow you to specify 
the position of the upper-left corner of the rectangle.    You can specify the position of 
the lower-right corner by entering its x and y coordinates or by entering the width and 
height of the desired rectangle.

You may save the cropped image directly to disk by means of the File menu, or you 
may capture the rectangle to the clipboard by pressing Ctrl+R or by selecting "Capture 
rectangle" from the Options menu.    To erase the rectangle, press Esc or position the
cursor anywhere on the image and click the left mouse button.

7.    File Menu

The File Menu has the following items:

    7.1      Save as BMP
    Select this menu item to save the contents of the clipboard to an uncompressed 
    Windows Bitmap File with the filename extension BMP.    Monochrome, 16-color, 
    256-color, and 24-bit TrueColor modes are supported.

    7.2      Save as GIF
    Select this menu item to save the contents of the clipboard to a CompuServe Graphics 
    Interchange Format file with the filename extension GIF.    This format utilizes LZW 
    compression, and supports monochrome, 16, and 256-color modes.    GIF does not 
    support 24-bit TrueColor modes.

    7.3      Save as PCX
    Select this menu item to save the contents of the clipboard to a PC Paintbrush file with 
    the filename extension PCX.    Monochrome, 16-color, 256-color, and 24-bit TrueColor 
    modes are supported.

    7.4      Save as PNG (Windows 95 & NT version)
    Select this menu item to save the contents of the clipboard to a Portable Network
    Graphics file with the filename extension PNG.    Monochrome, 16-color, 256-color, and
    24-bit TrueColor modes are supported.    

    7.5      Save as TIF
    Select this menu item to save the contents of the clipboard to a Tagged Image Format 
    file with the extension TIF.    Three compression modes are available: LZW, PackBits, 
    and no compression, any one of which may be selected from the Options menu.    The
    defaults are LZW for 24-bit TrueColor images, and PackBits for monochrome and                                            
    palette color images.

    7.6      Save as TXT
    Select this menu item to save clipboard text to an ASCII text file.    Two character sets 
    are available.    The OEM character set is the DOS-compatible IBM extended ASCII 
    character set.    The ANSI character set is the one used by Windows.    If you save text 
    to a file that already exists, the text will be appended to the file.

    The text that will be saved extends from the top of the Window, as set by the current
    vertical scroll position, to the end of the clipboard text.



    

    7.7      Open BMP
    Select this item from the File menu to open a BMP file and place it onto the clipboard.    
    The image can now be saved in any of the four available formats, or cropped and then 
    saved.

8.    Display Menu

This pull-down menu allows you to select which of the available clipboard formats to 
display.    Normally, Windows will clear the clipboard when the PrtSc key is pressed.    
However, applications can place a bitmap or text on the clipboard without first clearing 
it, so that text and graphics can coexist.    This is the case when you select Open BMP.    
By default, SuperClip will display the format most recently added to the clipboard.

9.    Options Menu

The following options are available:

    9.1    Capture rectangle (Ctrl+R)
    Select this menu item to capture the current rectangle to the clipboard.    You must 
    first draw a rectangle with the mouse or by entering coordinates from the keyboard.

    9.2    Clear clipboard (Ctrl+L)
    Select this menu item to empty the clipboard.

    9.3    Enter coordinates (Ctrl+E)
    Select this menu item to modify or draw a rectangle by entering its coordinates 
    from the keyboard.    The values that appear in the dialog box are those of the current
    rectangle, if one has been previously entered or drawn with the mouse.    If there is no 
    current rectangle, the values default to a rectangle that contains the entire client area 
    of the SuperClip window.    Coordinates may be entered that exceed the boundaries 
    of this client area, and may include the entire image on the clipboard, up to a full
    screen.

    The origin of the rectangle coordinates is the upper-left corner of the clipboard image.    
    To erase the rectangle, press Esc or click the left mouse button.

    9.4    Invert colors (Ctrl+I)
    Select this menu item to invert the colors of the image on the clipboard, creating 
    a negative image.    The original colors can be restored by selecting this menu item 
    again.

    9.5      PNG interlace (Windows 95 & NT version)
    Use this menu item to select whether or not PNG files will be interlaced.    

    9.6    Popup mode (Ctrl+M)
    This is the default mode of SuperClip.    When minimized or hidden by another window, 
    SuperClip will pop up onto the screen whenever a bitmap image or text is put onto the 
    clipboard.    Select this menu item to turn popup mode off or back on again.

    9.7.1    Reverse x-axis (Ctrl+X)
    Select this menu item to flip the clipboard image horizontally.    This will result in a 



    mirror image.

    9.7.2    Reverse y-axis (Ctrl+Y)
    Select this menu item to flip the clipboard image vertically.    The effect is the same as
    flipping a transparency over, top-to-bottom, and viewing it from the back.    To simulate
    the effect of turning an image upside-down, it is necessary to reverse both x and y axes.

    9.7.3    Stretch bitmap (Ctrl+S)
    Select this menu item to stretch or compress the clipboard image along the horizontal 
    and/or vertical axes.    Dimension limits are 1280 pixels horizontally by 1024 pixels 
    vertically.

    9.7.4    Text colors.
    This menu item allows you to choose the displayed colors of clipboard text.    
    The choices are black-on-white (the default) and white-on-black.

    9.8 Text to bitmap (Ctrl+B)
    Select this menu item to convert clipboard text to a monochrome bitmap image,
    so that it can be cropped or subjected to any of the other transformation options,
    and/or saved to disk in any of the graphical formats.

    The text that will be converted to a graphic image extends from the top of the window,
    as set by the current vertical scroll position, to the bottom of a full-screen image.

     9.9 TIF compression
    This menu item allows you to select the compression scheme for TIF files.    The
    choices are no compression, PackBits, and LZW (Lempel, Ziv, & Welch).    In the
    Windows 95/NT version of SuperClip, two modes of LZW compression are available:
    LZW 8k and LZW 16k.    The k refers to the number of kilobytes of raw pixel data
    compressed into each strip.    The conventional strip size in TIF files is 8k, but 16k
    yields better compression.    The defaults are LZW 8k for 24-bit True-Color images,
    and PackBits for monochrome and palette color images.

10.    Print Menu

Select this menu item to send clipboard graphics or text to the printer.    When printing a
graphical image, Windows first presents a dialog box that will allow you to select from
various options, such as resolution and intensity, then SuperClip presents a dialog box
that allows you to position the image on the page and stretch or compress it vertically
and/or horizontally.

When printing text, SuperClip first presents a dialog box that allows you to specify top 
and bottom margins, and the number of lines of text to print on each page.    Then
Windows presents a dialog box that allows you to select from various options, and
to specify how many pages to print.    Printing begins from the text at the top of the
window, as set by the current vertical scroll position.



11.    Help Menu

Online Help is available to explain the features of SuperClip, and includes a glossary 
of terms used in this document.

Select "System info" from the Help menu to display the resolution and color capability 
of the Windows screen driver currently running on your system.

12.    Registration

SuperClip (tm) for Windows, Shareware Edition, Version 3.25
Copyright 1994-97 AndroSoft (tm).      All Rights Reserved.

The Professional Edition of SuperClip does not superimpose any
shareware notice or logo on saved or printed images.

To register and receive your licensed Professional Edition, fill
out the Order Form and mail, e-mail, or fax to

                                            AndroSoft
                                            125 N. Prospect St.
                                            Washington NJ    07882
                                            U.S.A.

NJ residents please include sales tax.

Steven A. Brown, Programmer
E-mail: 73140.3340@compuserve.com
Fax: 908-689-0047

AndroSoft is a growing business and it may become necessary in the future for us to 
relocate.    Our postal address, fax and telephone numbers may change, but our e-mail 
address will stay the same.    You will therefore still be able to contact us by e-mail, 
even if attempts to contact us by other means fail.



CREDIT CARD ORDERS

You may e-mail or fax your order with your name, address, VISA, MasterCard, 
or American Express account number, and expiration date.    Please include your 
signature on fax orders, and specify one of the following methods of delivery:

1.    First-class air mail on 3.5" disk.

2.    SCLIP-PE.ZIP via e-mail to a CompuServe address.

3.    SCLIP-PE.ZIP via e-mail to an America Online address.

4.    SCLIP-PE.ZIP via Internet e-mail (requires your e-mail software to have MIME
          capability, indicated by a line in the header of your messages that begins with
          "MIME-version:"

5.    UU-encoded SCLIP-PE.ZIP via Internet e-mail (requires UUDECODE.EXE utility
          to recover ZIP file).

Registration fee is $39.00 for one pc, plus $10.00 for each additional pc or workstation
on which SuperClip will be used.    Shipping via e-mail: $1.    Via first-class air mail: $1 to
North America, $2 elsewhere.    Additional copies on diskette: $1 each.    Residents of
New Jersey please include sales tax.

Orders may also be placed by telephone to (908) 689-0047.

SITE LICENSING

A site license is available for the very reasonable fee of $10 for each additional pc or
workstation on which SuperClip will be used.    To obtain a site license, fill out and submit
with payment the Order Form in the text file order.frm.

13.    Legal Notices

SHAREWARE NOTICE

The Shareware Edition of SuperClip may be freely distributed.    You may use it over a 
fifteen-day period to determine its suitability for your needs.    To continue using SuperClip
beyond this evaluation period, you will be required to purchase the registered Professional
Edition.

Registration fees are the only compensation the programmer receives for the work 
and expense of writing this program.    Please support the shareware concept of quality, 
"try-before-you-buy" software.    Registered users are entitled to unlimited technical
support and low-cost upgrades.



DISCLAIMER OF WARRANTY

THIS SOFTWARE IS SOLD "AS IS," WITHOUT WARRANTY AS TO PERFORMANCE
OF MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR
IMPLIED.    BECAUSE OF THE VARIOUS HARDWARE AND SOFTWARE ENVIRON-
MENTS INTO WHICH THIS PROGRAM MAY BE PUT, NO WARRANTY OF FITNESS
FOR A PARTICULAR PURPOSE IS OFFERED.    GOOD DATA PROCESSING PRO-
CEDURE DICTATES THAT ANY PROGRAM BE THOROUGHLY TESTED WITH NON-
CRITICAL DATA BEFORE RELYING ON IT.    THE USER MUST ASSUME THE ENTIRE 
RISK OF USING THE PROGRAM.    ANY LIABILITY OF THE SELLER WILL BE LIMITED 
EXCLUSIVELY TO PRODUCT REPLACEMENT OR REFUND OF PURCHASE PRICE.

LZW LICENSE NOTICE

Use of this software is permitted only to the extent reasonably required to determine 
whether to purchase the software.    After payment is made, use of this software is limited 
to use on only a single personal computer or workstation which is not used as a server.    
An additional payment of $10 is required for each use on another personal computer 
or workstation.

Only a single copy may be made of this software solely for backup or archival purposes.    
The software may also be transferred to a single hard disk.

Any use of this software in violation of the above is not licensed.

For information concerning licensing the LZW compression and/or decompression 
capability, please contact:

          Unisys Corporation
          Welch Licensing Department - C1SW19
          Township Line & Union Meeting Roads
          P.O. Box 500
          Blue Bell, Pennsylvania 19424

Graphics Interchange Format and GIF are service marks of CompuServe Incorporated.

14.    AndroSoft Home Page

The current version of SuperClip Shareware Edition is always available for download
from the AndroSoft Home Page on the World Wide Web.    The URL is

http://ourworld.compuserve.com/homepages/andromeda



15.    Support for SuperClip on CompuServe

The Shareware Edition of SuperClip can be found in the WINSHARE Forum on
CompuServe, an official distribution and support online resource for future updates.
Search for SCLIP.ZIP.

The Windows Users Group Network [WUGNET], operators of the oldest and largest
independent support resource forum [WINUSER] for Windows users on CIS with over
1,000,000 active members is recognized by the press, user groups, developers, and
Microsoft as the foremost resource for shareware publishers on CompuServe and the
Internet.

16.    APPENDIX - VESA modes supported by DosClip

In addition to the standard VGA modes, the following VESA SVGA graphical screen 
modes are supported by DosClip:

MODE     PIXEL RESOLUTION    NUMBER OF COLORS

100h      640 x  400                256
101h      640 x  480                256
102h      800 x  600                 16
103h      800 x  600                256
104h     1024 x  768                 16
105h     1024 x  768                256
106h     1280 x 1024                 16
107h     1280 x 1024                256
10Fh      320 x  200         16,777,200
112h      640 x  480         16,777,200
115h      800 x  600         16,777,200
118h     1024 x  768         16,777,200
11Bh     1280 x 1024         16,777,200

                  #  #  #


